Starting Point Issue With Kali Linux Impacket

Hi there,

As the title says I’m having a few issues with the Impacket tool in Kali Linux.

I’ve installed it from the unpacked zip via “sudo pip3 install .” and it seems to be in my python3 dist-packages folder.

But when I try to run the part of the Starting Point tutorial I just get back "can’t open file ‘ : [Errno 2] No such file or directory’

I’ve tried uninstalling the package and re-installing but that hasn’t helped. It might be worth me completely removing python and reinstalling it but I know that can be troublesome on Linux.

Does anyone have any recommendations?

*UPDATE I looked inside the unzipped folder for Impacket under /impacket-master/examples and found the and just ran the file via that way which worked :slight_smile:

From memory if you run the ‘pip install .’ (need to install pip for this) then that will cover it as well.
As in; it will setup the path for you so you don’t have to run the impacket scripts using the full path for each python script.

Yep, gotta be mindful of where you are when you run the command. If you don’t want to navigate there every time, you’ll still want to call the file by its full path. Or add it to PATH, though that might be excessive for one python script.