Starting point: included - fail to build alphine

Hi all,

When I step-by-step went thru the starting point “included” walkthrough I failed to build the alpine image with the following error. I googled a while and found someone said that this is related to rotating keys. I tried to use "udo $HOME/go/bin/distrobuilder build-lxd alpine.yaml -o image.release=3.8 -o source.same_as=3.16 " but no help.

Do you have any idea on this? Thanks in advance.


ERROR: unable to select packages:
doas (no such package):
required by: world[doas]
Error: Failed to manage packages: Failed to install packages: exit status 1
ERROR [2023-05-20T05:06:18-04:00] Failed running distrobuilder err=“Failed to manage packages: Failed to install packages: exit status 1”
INFO [2023-05-20T05:06:18-04:00] Removing cache directory

maybe try to verify the availability of doas package.

apt search doas

Hello Marek33366,

I tried. Yes, doas has been installed in my machine. After a few trial-and-error. I successfully built alpine container by “sudo $HOME/go/bin/distrobuilder build-lxd alpine.yaml -o image.release=3.8 -o source.same_as=3.12”

Thanks for your help anyway.

Best regards,

1 Like

Hi godchild,

Try using following command. This will work for you.

sudo $HOME/go/bin/distrobuilder build-lxd alpine.yaml -o image.release=3.9