SSH error "No route to host"

Im trying to connect to the target and I keep getting “No route to host” error.
I tried to use verbose to gain more info and here is what I got:

ssh -v htb-student@
OpenSSH_8.4p1 Debian-5+deb11u1, OpenSSL 1.1.1n  15 Mar 2022
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: include /etc/ssh/ssh_config.d/*.conf matched no files
debug1: /etc/ssh/ssh_config line 21: Applying options for *
debug1: Connecting to [] port 22.
debug1: connect to address port 22: No route to host
ssh: connect to host port 22: No route to host

Im doing this all on my virtual box with parrot os htb edition.
I tried to disable fireawll in windows but it didnt helped

Hey! Did you double check your Academy VPN?

Check that you have an IP:
ip addr show tun0

And check that you have the right routes with:
netstat -rn

Or ip addr show should display all interfaces if tun0 isn’t configured.`

Try a ping of that IP address too and make sure you can ping it.

Thank you for replying!
I cant ping th ip be cause something is wrong with the vpn i suppose.
I noticed that vpn log has some errors

ble 0 metric -1
2023-08-24 21:11:21 sitnl_send: rtnl: generic error (-17): File exists
2023-08-24 21:11:21 NOTE: Linux route add command failed because route exists
2023-08-24 21:11:21 net_route_v4_add: via dev [NULL] table 0 metric -1

My guess is that solving this issue will fix everything.
I believe that I have to delete existing routes somehow.

I entered
sudo ip link delete tun0
and i didnt fixed anything.

I then restarted VM and now im just getting connection time out