SQL Injection Fundamentals - Connection issue

I cannot connect to the server

mysql -u root -h -P32366 -ppassword --protocol=tcp
ERROR 2002 (HY000): Can’t connect to MySQL server on ‘’ (115)

i have tried the same without the protocol part and with the password being inserted after the command

Searching the issue up on the net did not help (eg. installing client and server versions)

VPN is working fine since i can connect to Getting started boxes and i have tried reinstalling it since ping was not working either (that too worked with getting started)

I have had a problem with SQL before on a easy box on hackthebox box

did you put a space between -P and the port # 32366?
-P 32366

If i do recall correctly i have but i will do that just now to douple check
But i still cannot ping the server so im still assuming there is a connection problem

RESULT: Ok i did not even get to the part where i was going to try your solution out. I just copied the command in my original post and changed the port & IP and it worked. Guessing its a problem with my own PC though since i have not read about lots of problems with SQL so far that are like mine and the fact that ive had problems with SQL before

POST NOTE: I did the first excersize and now the same thing has happened on “SQL Statements”. Again cannot connect with 2002 HY000 as the error (Ping does not work either)

whenever that happens try disconnecting the VPN then reconnecting, if you have not tried that already that is.

Sadly does not fix. Again having the issue

Can connect when i skip a part. In this can could not get a connection in “Union clause” but can get a clear connection to “Union injection”