Pivoting, Tunneling, and Port Forwarding / SOCKS5 Tunneling with Chisel

Hi everyone,

may I please ask you if anyone is also having the same issue on the module Pivoting, Tunneling, and Port Forwarding , part SOCKS5 Tunneling with Chisel where the Pivot Host / Ubuntu server is not updated and cannot run binary chisel. As per [chisel github](https://github.com/atanunq/viu/issues/68) some of the recommendations is to update the machine.

So, when I transfer the binary chisel on the pivot host and try to run the command ./chisel server -v -p 1234 --socks5 I’m getting a following error message:

ubuntu@WEB01:~$ ./chisel server -v -p 1234 --socks5
./chisel: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.32' not found (required by ./chisel)
./chisel: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.34' not found (required by ./chisel)

Any help or suggestions would be helpful.

Thx

Same here. did you figure this out?

1 Like

To be honest, I didn’t want to play now with old libc and therefore I just took an another tunneling method in order to get the flag. The pivot machine needs to be updated in order to be able to run the chisel binary file.

I see, thanks.

An easy way is to download the build v1.7.4 from GitHub. It’s old enough to run on the host.
In general, you can’t ask the target to adapt to you… :slight_smile:

7 Likes

Thanks, that fixed this error for me!

Hi, I tried using chisel-1.7.4 but it still doesnt work. I get the exact same error message. What I do is build the source code with “go build” and then I transfer it over to the pivot. Should I use another way to compile or what?

Hi.
I’ve used version 1.5, and in particular chisel_1.5.2_linux_386.gz
Hope will help.

1 Like

hi!
by studying this forum i tried to move 1.7 and 1.5 both in the ubuntu. but still facing the same error

and same issue in ICMP one

I am able to resolve it by building a static binary

go build --ldflags '-linkmode external -extldflags "-static"'
4 Likes

try 1.5.2 version link download linux amd64.gz file

1 Like

To be honest with you all, I found this part very strange. Even though I tried through multiple ways to reach the DC and login via RDP on the DC as the user they suggest, I always got errors on xfreerdp like:
[ERROR][com.freerdp.core.connection] - Timeout waiting for activation
[ERROR][com.freerdp.core] - freerdp_abort_connect:freerdp_set_last_error_ex ERRCONNECT_CONNECT_CANCELLED [0x0002000B]

Edit: Solved! The fact that we are connecting to a DC is something to be considered.