Pathfinder- BloodHound GUI Freeze on Analysis Filter

I am working through Pathfinder. BloodHound loads fine and displays data, neo4j seems operational. Both are up to date. I was able to successfully import .jsons individually and as a .zip archive

PROBLEM: BloodHound GUI freezes when I add analysis filters. In the bottom I see “Initial Layout” or similar and the program becomes non-responsive. Tried waiting 20 minutes. Confirmed neo4j running.
*Some filters will work, like “Find all Domain Admins”

Actions to Try and Fix:

  1. I uncommented a config setting around line 60 “dbms.default_listen_address=” to allow remote connections and returned to default when it did not work.
  2. Tried with HTB vpn on and off, I understand I should need internet access.

Running on a vm with 5900x so is this a graphics or vram issue with no integrated graphics, maybe?

STILL STUCK. Probably going to cheat with a walkthrough, but want to know why I cannot operate this tool.

Analysis Filter, as in “shortest paths to high value targets”, for example. As soon as I click on the domain prompt “local.megacorp”, bloodhound locks up.