PASSWORD ATTACKS -- crackmapexec instalation

I’ve been having some trouble installing crackmapexec package on the Parrot OS.

In the PASSWORD ATTACKS module, section Network Services, the crackmapexec package is used for brute forcing some passwords but the installation process, described there with following:

$ sudo apt-get -y install crackmapexec

fails with:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 crackmapexec : Depends: python3-lsassy but it is not installable
                Depends: python3-neo4j but it is not installable
                Depends: python3-pypsrp but it is not installable
E: Unable to correct problems, you have held broken packages.

After digging in as to why this wont work I decided to download it from official repo and build it myself.
I tried

  • Installing from Source (with Poetry) – unsuccessfully bcs of aardwolf package which failed building. (tried to figure out why for a while but then gave up as well)
  • Python Package – unsuccessfully as well. Cant remember exact issues.
  • Lastly downloading the Binary from release – Still unsuccessfully with some more aardwolf errors if I recall correctly.

I am in the Attacking SAM section atm, and I’m supposed to use crackmapexec once more for the Remote LSA Dump, and, once more, I went through all the options for installation.

Is anyone having these issues as well? I have not found any Topics here on the forum discussing this, yet found active Topics on this particular module :face_with_spiral_eyes:.

try the following: Python Package

2 Likes

Not sure what I did wrong in the first try, but this time around it worked …
Thanks

You are not alone. Met same problem now. I ensure I did not do any wrong previously. And also did apt update -y and apt dist-upgrade -y before I proceed.

That’s weird.

Well, there must be some issue on Parrot side, I tried live ISO, also not working.

Thanks for sharing, it’s work. :wink:

this helped! thanks a bunch