Hi Everybody

is anyone else having trouble with the newest version of OpenVPN not being able to connect to labs or startpoint, I spun up an older machine from before the update and connects fine

not working –
OpenVPN 2.6_git x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] [DCO] built on May 30 2022
library versions: OpenSSL 3.0.3 3 May 2022, LZO 2.10

working –
OpenVPN 2.5.5 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 21 2022
library versions: OpenSSL 1.1.1m 14 Dec 2021, LZO 2.10

was wonder if anyone had the same problem and how you got around it?


Check this.


cheers thanks dude

OpenVPN provides flexible VPN solutions to secure your data communications, whether it’s for Internet privacy, remote access for employees, securing IoT, or for networking Cloud data centers.

Method to fix OpenVPN issue-
Method 1: Reset the TAP Adapters Manually
In Paul’s case, he did not receive a ping response, even with the firewall disabled on the remote machine. Since Paul has not made any configuration changes to OpenVPN recently and because ping did not provide a response, the next thing to try is to reset the TAP adapters in Windows to “clear” the connection.

TAP adapters are virtual network card adapters and allow the local and remote machine to operate on the virtual network; oftentimes these adapters become “corrupted” and need to be reset. Note that rebooting the machine would not be enough to fix the issue - the adapters need to be reset manually.

To do so:

a) Close down the OpenVPN GUI on the local machine and stop the OpenVPN server service on the remote machine.

b) Click the Start menu, then type in “network and sharing center”; click the “Network and Sharing Center” icon when it appears, then click “Change adapters settings” link near the top right of the proceeding window.

c) The “Network connections” window will appear. For every “TAP adapter” you see, right click it and select “disable”.

d) Now, re-enable the TAP adapters. Right click each disabled TAP adapter and select “Enable”. Disabling and then re-enabling the adapters will reset the adapters, clearing any “corruption”.

e) Re-launch OpenVPN server on the remote machine and OpenVPN GUI on the local machine; attempt to connect.

f) Once the connection is made try launching Remote Desktop (RDP) to open a remote desktop connection on the remote machine.

Method 2: Ensure RDP Services are Enabled and Running
If Remote Desktop Protocol (RDP) is still not working at this point, you will want to make sure that RDP is in fact enabled on the remote machine and the service is running.

To do so:

a) Go to the remote machine, then click Start and type in “This PC”; wait for “This PC” to appear in the list, then right click it and select “Properties”.

b) The “System” window will appear; click the “Advanced System Settings” link near the top left, then click the “Remote” tab near the top right. Look under the heading “Remote Desktop” and ensure that “Allow remote connections to this computer” option is enabled. Click “Apply” and “OK” to finalize any adjustments.

c) Next, you will want to ensure that the Remote Desktop Service is running. Click Start, then type in “services.msc”; wait for “Services” to appear in the list, then click it. Scroll down to “Remote Desktop Services”, then double click it. The “Startup type” should be set for manual. The heading “Service status:” should say that it is running. If it is not running, click “Start” to start the service, then try connecting again. It should work. If it is not working, you are welcome to contact me for additional support, described next.
Rachel Gomez

1 Like