Oopsie - Reverse shell issue

Hey there guys,

I would need a little bit of help on an issue which I am not able to solve by myself. I am currently stuck on the "Oopsie " machine. In particular the terminal freezes at this exact moment:

Any Idea what could be the issue here? I tried to search the forum but couldn’t find anything.

Thanks in advance for the help.


I’m facing exactly the same issue. Anyone have any idea?

Sadly I tried to find a solution by myself but nothing was mentioned which i could use. So nobody has a solution for that? Or can drop a hint what could be the issue?

Well, i did encounter the same problem a few weeks ago. I found out why the commands where not working like expected. If i remember correctly it has something to do with the fact that the default shell in Kali 2020.4 has changed from Bash to ZSH and that ZSH processes the commands a little bit different. Try to give the ‘stty raw -echo’ and ‘fg’ command in one line like this: ‘stty raw -echo; fg’.

Does this solve your problem?

I faced with this problem too and in my case, the problem was the script I was using. Because I was not able to find php-reverese-shell.php in my system, I just copied the code from the Walkthrough PDF and pasted and edited using nano. It took me some time to realize that somehow the file was missing some comment slashes, and I started to think that maybe that was not the only problem with this copy & paste approach. So I ended downloading the file from pentestmonkey.

  1. Download the .tar from this page: pentestmonkey php-reverse-shell
  2. Extract the .tar and open the .php file using your favorite editor
  3. Make sure that you use the IP given under tun0 that you can find doing a ip a
  4. I used the standard given port to listen: 1234
  5. Follow the other instructions from the PDF

I hope this may help others facing the same problem.