Kali issues

Hi all,
I have been working through the retired machines using Kali and learning so much but have recently had some issues with my Kali install.
I have had not too many issues getting user and root on machines and going through the tutorials when i get stuck.
But yesterday i started on Bounty and it has been the biggest headache.
I got RCE quite easily from that got a basic reverse shell but once i started trying to get priv esc the box would not send any shells back to my kali box, went through everyone i could find, still nothing, so i went down the tutorial path and metasploit but still no shells would come back probably took 12 hours and no luck.
This morning i got up and thought this cant be right there must be something wrong i am not seeing, so for the sake of troubleshooting i ran up a copy of parrot security. Within 10 minutes i had root and everything i tired yesterday worked fine. Went back to Kali and still none of the second reverse tcp connections would work.
Can someone push me in the right direction of what could be going on, I have gotten so used to Kali it would be a shame to have to go to Parrot just because of a glitch.


you could check iptables or any firewall installed