Issue with gobuster (version command not working). Unable to finish crocodile machine

Hello everyone,

I’m having some issues with gobuster in Ubuntu 22.04.2.

When I try the command sudo apt-get -y install gobuster the message is the following:

gobuster is already the newest version (2.0.1-1build2)

But, when I try the command:

gobuster version

I get message:

2023/04/29 22:02:46 [!] 2 errors occurred:

*** WordList (-w): Must be specified (use -w - for stdin)**

*** Url/Domain (-u): Must be specified**

And even trying to use it in the Crocodile (starting point machine) in the following way:

gobuster dir -u http://IP/ -w ~/SecLists/Discovery/Web-Content/directory-list-2.3-small.txt

I get the same previous message.

Can anyone please help me in the usage of these app? Is there something I could have done wrong in the installation?

That is strange! you can try using ffuf as an alternative.
Lemme check how I use my gobuster (and version)

1 Like

Hmm, I think the version I use is 3.1.0 and it works just fine :frowning:
You can try building from the sources
Or consider using ffuf -w <wordlist> -u "http://<ip>/FUZZ" -fs <size-to-skip>

1 Like

Thank you for the reply! Even though I couldn’t get the gobuster working, I could use the ffuf tool with no problems. I didn’t got the same exact results. In matter of fact, I didn’t get the supposed login.php that I would get with the gobuster -x command. But I could get the flag by using other of the results I got with ffuf.

So, to sum up, even though this answer didn’t help me to solve the actual gobuster problem, it did helped me to solve the machine, so THANK YOU!

1 Like

for ffuf there is an option for that

 -e               Comma separated list of extensions. Extends FUZZ keyword.
1 Like

I had the same exact issue, the problem is when you run the usual install way it’s an outdated version. You have to follow their GitHub build instructions and after building it within a go enviornment. It should work .

i faced same issue so i tried " -e " in-place of " dir " in cmd as
" gobuster -e -u http://192.168.0.155/ -w /usr/share/wordlists/dirb/common.txt "
it worked for me.
read from here gobuster | Kali Linux Tools

1 Like

wow!! thank you very much! this is a first answer that reily work for me!