I cannot download the openvpn file

Randomly on Wed this week my OpenVPN file wouldn’t connect and kept failing due to a failed handshake. When I get “Download VPN” from either UDP or TCP I get an error message “The VPN Server is currently unavailable. Please try again later.”

The weird thing is I don’t have this issue with the Starting Point, it’s just with the Machines.
I also, have tried it on a different PC and with a VPN.

Does anyone know what could be happening?

It may be due to many people accessing the website at the same time causing bandwidth issue.
You said that you saw

The VPN Server is currently unavailable. Please try again later

I tried just now, and it is working
can you try it again?

I tried it again today and yesterday without luck

I was able to figure out the issue. I had an active machine running and it wouldn’t let me download the file because of that. Once, I left the machine I was able to download a new VPN file.

I am grateful that the issue is solved
Happy Hacking