Get-CimInstance or Get-WmiObject not working on target machine

Hey everyone ,

So , I started with “Introduction to Windows” of Windows Fundamentals and I got stuck at the first challenge itself .

So the challenge asks me to RDP into a target machine using the IP address and username and password provided and through “xfreerdp” I can do that , that I am able to access the target machine but when I open powershell from the titlebar above or by just going into menu and opening “powershell” and when I try to type the below commands I am getting the following output , which is not what I want :

Get-WmiObject -List

Get-WmiObject: The term ‘Get-WmiObject’ is not recognized as a name of a cmdlet, function, script file, or executable program.
Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

So , I saw a similar thread which suggested other user that they are not accessing powershell but the thing is I am clicking on “Menu” and then literally clicking on “powershell” that is showing up in the menu .

I googled on how to solve this error and I was able to find from this link that Get-WmiObject has been deprecated and I should instead be using Get-CimInstance and even I tried that I got the same error that I was getting for Get-WmiObject just with different name which was of “Get-CimInstance” .

Please help me on this , Any help or suggestion would be tremendously appreciated , Thank you so much !

Regards
Me