FTP "GET" command not working in Starting Point: Level 1: Crocodile

I’m completing the Starting Point, Level I Crocodile exercise. I get an error when I use the “get” command.

I log in with ftp (target ip)
then I type in {dir} and it lists two files: allowed.userlist and allowed.userlist.passwd

I type {get allowed.userlist} and I receive this error:

“local allowed.userlist remote: allowed.userlist
local: allowed.userlist remote: permission denied”

What do I do to fix this?


Did you ever get this figured out? I’m hitting the same wall.


permission denied, while getting the file means, the ftp user does not have read access to the file.
Try checking if the file has read access or not, by using “ls -la”.
Then type the command “binary”. Then use get command see if it works or not. Else you can reset the machine if everything fails.

Has anyone fixed this already? I have the same problem :confused: Tried already to reset the machine and everything.

Didn’t work for me :frowning:

Fixed it! Use “sudo” before you start the ftp access.

sudo ftp {target_ip}

although sudo will help you, it all depends on the dir you were in when you initiated the ftp connection. Since the get command will write a file into the dir you initiated the connection, you first need to have write permission in that dir, therefore the need for sudo. Tried it and initiated the connection from my home dir and i didn’t need sudo to get the flag.txt since i have write permission on my home dir.