Deadly arthropod

Hi,
Have several questions regarding Deadly Arthropod. Can anyone help in PM?

same problem occure …lol

If you’re doing this one, a fairly obvious blog post is missing some key information, try and understand what every byte means

Hey guys, I was able to recover two clear pieces of data but don’t know what to do with them. Any hint? (If I should include more info about those pieces I will, just don’t wanna spoil more than necessary).

I’m in a similar situation. I was able to extract the key but I seem to be having some issues with character encoding on one of the letters. I have a discernible flag in the “HBC{}” format but when i try to submit it I’m getting “Incorrect Flag”. I know it has something to do with this one damn character. If someone figured this one out, could you PM me. I’ve tried every variance of the character I could find to no avail.

It seems you know what to do, check the specification of what you’re reversing , make sure you’ve got every part correct and check your assumptions

Yeah, I am seeing the same issue. Need to expand options.

Anyone around for a quick question on this? I have a couple of questions. So close!

When I did this, I found that there is a mistake with the first letter of one of the words being in front of the string and not being put in the correct place. Just try to make the most “legit” sentence you can out of the letters that are there.

hmm, I have been playing with mappings. I keep getting the first two faux flags no matter what, but the next one doesn’t make sense. I think I must find some mapping that is unique to that device. In my print debugs, I am getting a couple numbers that repeat multiple times. Not sure what that is about.

@waywardsun said:
hmm, I have been playing with mappings. I keep getting the first two faux flags no matter what, but the next one doesn’t make sense. I think I must find some mapping that is unique to that device. In my print debugs, I am getting a couple numbers that repeat multiple times. Not sure what that is about.

Ah, yeah those two numbers that you haven’t figured out yet are VERY important to solving the challenge. Once you find the correct list of mappings and figure those out, you will get it quickly after that.

Well, it is good to know I am on the right track. Thanks!

@waywardsun said:
Well, it is good to know I am on the right track. Thanks!

For sure. I found a certain PDF file that has mappings for USB_HID devices of the type of device that is being used… no spoilerino… :slight_smile:

Still at a deadlock with this one. I have the key and it’s a discernible key… makes s3nse and it’s in the right HTB{key} format… just not accepting it. I looked at a certain PDF with USB_HID device key mappings and also looked at a certain h file that had these mappings listed. Wrote a script to parse/iterate over the needed data and there are potentially two keys that aren’t 100% what they are. I’m not finding a device-specific (or product specific) PDF… Just not sure where to go with this. I’ve spent a week on this and i keep coming up with the same answer and no new resources. Anyone have a nudge on this? It’s driving me up a wall (because the key looks to be correct).

If you have a key that looks legitimate in HTB{} format, check the logic of your parser - you’ll need to wrap the input around in certain cases.

@kophjager263 - you could PM me the key you come up with and I can try to figure out where you’re misstepping and then point you to a way to see it yourself… :slight_smile:

@kophjager263 said:
Still at a deadlock with this one. I have the key and it’s a discernible key… makes s3nse and it’s in the right HTB{key} format… just not accepting it. I looked at a certain PDF with USB_HID device key mappings and also looked at a certain h file that had these mappings listed. Wrote a script to parse/iterate over the needed data and there are potentially two keys that aren’t 100% what they are. I’m not finding a device-specific (or product specific) PDF… Just not sure where to go with this. I’ve spent a week on this and i keep coming up with the same answer and no new resources. Anyone have a nudge on this? It’s driving me up a wall (because the key looks to be correct).

I’m in the same boat, stuck for some days, I have the key also, and it make senses to me, but it’s not accepting it either.

Couldn’t find anything special for this device model …

I’m sure i’m missing something, but what? Any clue?

I think i am on the same problem as others i think. I found email and the password for. But then i got strange 2 codes that i can’t put anywhere. Any hints for this 2 codes? PM please.

oooo i am so stupid i figure it out.

@escugs said:
oooo i am so stupid i figure it out.

could you please explain?