Can't connect to openvpn

I’m trying to connect to openvpn for hackthebox using this command:

$ openvpn my_vpn_file.opvpn

And I get this error:

Options error: Unrecognized option or missing or extra parameter(s) in my_vpn_file.ovpn:12: data-ciphers-fallback (2.4.12)

I looked in the file, and line 12 is this option:

data-ciphers-fallback AES-128-CBC

I have absolutely no idea what I’m doing, this is the first time I’ve used openvpn. Any advice? Thanks!

I deleted the parameter that threw the error until it ran, and then it just got stuck in a loop of the tls handshake failing, then I tried to regenerate the VPN file, which made it run without having t delete the option but the same thing happened.

have you tried sudo ?

did this helped you out ?

Sometime - sudo openvpn --config file.ovpn also works so you can try this

Use linux openvpn on Mint Linux Linux Mint 18.3 Sylvia \n \l … the config files provided by perfect had parameters that were calling out errors…

I removed the single line that had the string “ncp-disable” and “compress”, and all was well afterwards.