Burp not working on htb boxes

I am using foxproxy and i established burpsite in that . All other websites are passing through proxy but htb boxes are not seen on burp.

@sandeysh said:

I am using foxproxy and i established burpsite in that . All other websites are passing through proxy but htb boxes are not seen on burp.

So I can 100% guarantee that it is a problem with your configuration or install of burp here.

If other sites are passing through you probably need to check you haven’t disabled an IP range or configured either foxyproxy/browser to go direct for certain ranges.

First off make sure you can connect to HTB boxes normally, then make sure all protocols are routed through burp, then start troubleshooting the data you have.

I am using kali linux and i have burp preinstalled in kali . All the websites are passing through burpsuite except htb box.There were no ip ranges that were disabled.

It might be that Burp or your browser is configured to not proxy local address ranges (e.g. 10.10.10.x ).

@sandeysh - is there any more specific error information?

Does burp simply not intercept the requests but the browser goes to the page?

Have you tried turning foxproxy off and manually configuring it to use burp?

Have you checked it against any other RFC1918 private internets address ranges?

I can confirm that at least two boxes are working right now with burp, so the reality is an issues here are on your box.

You need to work through each step and confirm your assumptions, the only way this would be happening is that your browser isn’t using Burp as a proxy for the HTB address ranges or domain names.

Try adding the HTB host to your target scope (Scope Tab) in Burp, and see if your able to intercept requests/responses to/from the HTB host then.

Also, like @TazWake mentioned above, I would ensure that FoxyProxy is disabled first before utilizing Burp Proxy. Ensure under your Proxy tab in Burp, that it is in fact running on the specified interface:port. I am currently able to see HTB boxes in Burp, especially when they are included as part of the scope.

I hope this helps!

eZ - termtype

I’m having exactly the same problem all of a sudden. Only affects the HTB machine I’m not. All other traffic is intercepted. Happens with manul proxy settings as well as foxyproxy.

I can confirm what you observe. I use Parrot. Suddenly HTB boxes went “out-of-scope” even though correct entry is present in Burp settings. I suspect some default option changed somewhere with an update. I thought that it was my fault but couldn’t put my finger on it.
I worked around problem using FoxyProxy addon for Firefox and setting rule that all “.htb” machines are proxified, but others are not. In Burp I log all connections (Out-of-scope connections too, but addon filters them anyway).

Has anyone got an update on this topic? I am experiencing same situation with burp not sending .htb sites through proxy. All traffic is intercepted except .htb sites which just go straight to site in browser. Tried uninstalling/re-installing burp and firefox but nothing changed.

I was pwning the tier 3 “Unified” box, and i had the same problem… the fix? you have to enable the HTTPS proxy on Firefox proxy configuration. I was only configuring the HTTP protocol, but this machine are running under HTTPS. I just enabled the on HTTPS and burp run good as always.

May the hack be with you…!

i changed the burp proxy listening port 8080 to 443 and problem resolved

Hmm… that didnt work for me. I have/had the Always use this proxy for HTTPS checked so essentially its the same as you have above.

I get this now from Burp Suite

“Unsupported or unrecognized SSL message”

What worked for me is Settings > Burp Browser > Allow Burp to run without sandbox TICK

I also added the .htb host into the network > Connections > Hostname Resolution overrides