ARCHETYPE no connection to web server

so i got up to the point where i have to run the webserver and netcat they say they running but when i try use the xp_cmdshell cmd on sql it doesnt do anything

the ip adress is corectly adjusted in file

both webserver and netcat are running in the same folder as my shell.ps1 is located
vpn is up and running

anyone got any tips?

Maybe try reconnecting your mssqlclient (exit, then run again). Could be that it lost its connection somewhere along the way (maybe the machine got reset). At least I think that is what happened to me sometime before. Sadly impacket’s does not seem to report lost connections in any way, as far as I can tell.

wel tried it all again now i can actualy see a reply from sql but no succes yet on nc and web server

Exception calling “DownloadString” with “1” argument(s): “Unable to connect to the remote server”

At line:1 char:1

sudo python3 -m http.server 8
Serving HTTP on port 8 ( …

sudo nc -lvnp 443
Ncat: Version 7.91 ( Ncat - Netcat for the 21st Century )
Ncat: Listening on :::443
Ncat: Listening on

the webserver is ok now - - [12/Mar/2021 07:32:26] “GET /shell.ps1 HTTP/1.1” 200 -
but still nothing on netcat
and also got a lot off errors is sql string related
all help is still welcome

case closed got root flag
and for those struggeling keep double checking

hi i have problem with command sudo nc -lvnp 443 when i run it it type listening on any 443 port pls help bro

are you running it in the map where your shell is located?

my shell is on same folder HTB/startingpoint

well thats was one my issues
maybe another thing to try is restart you machine
and go true the sql part again and then the nc and webserver
andtry it again it worked for me

I did it i hacked it