0xDiablos

I just have finished the 0xDiablos pwn challenge, on my local machine, but when I connect to the remote host (the docker) and send the challenge string, the server doesn’t respond me anything.
I’ve tried with nc and telnet, and they both let me hanging on idk why :
I don’t think that this is part of the challenge, because when I send normal messages, like “testing”, or “hello”, the server responds me with the same message, but when I send the solution, it freezes

I have even test my solution locally creating a flag.txt file, and the vuln file outputs it… So it just proves my point even more

I am working on it but I think it is beyond my knowledge in this area. What you should check if the parameters you send to the function are correct.

< CLEARED >

I encountered the same problem, and just reading again from the socket works. It sends the echo message first, then the flag, so I had to read twice.

Hi,

can someone direct me to the right resources for understand how to solve this kind of challenges?

Thanks.

I found this valuable: PWN methodology — LINUX. This is my current methodology for… | by Karol Mazurek | Medium

Cheers

Thanks!