What is the type of the service of the "syslog.service"?

For some reason I spent half an hour trying to find the answer that’s pretty easy to find if you know how. So to find the type of a service you just need to use the show command. Something like this: systemctl show syslog.service
or just to display the type you use this:
-p stands for property, extracted from the help page the -p command descriptions is “Show only properties by this name”.


what is the answer?

You can spin up a virtual Linux system if you’re on MacOS/Windows and run the command the original poster has provided.

1 Like

You should get the answer after running the command I took a screenshot of.

Not work

Sorry to hear that can you explain more. What is the error you get? Is there any error or is the response just blank? If something else is the problem please screenshot it and hopefully me or someone else in the community will help you. Maybe it is dumb to say it at this point but check the spelling one more time.

Not work

1 Like

It so blank response

Can you take a screenshot of the problem or at least elaborate.

Hi, it took me some time to answer, I barely have any time in my day and I try to help as many people as I can. Hopefully this is the answer you are looking for. So I tried to do the same command in my virtual machine and it didn’t work:
ran a few commands and got this(don’t mind the name of the directories):
so this meant I didn’t have it installed on my system so to do that you first want to type:
apt update && apt upgrade -y
apt install rsyslog
That’s it once you run the command I originally posted hopefully you will get the answer!

1 Like

Thanks for the tip.
But even knowing the answer, I don’t really understand the purposes of the question ?

this is the screenshot from the debian site, link:systemd/Services - Debian Wiki. if you want the full explanation:


the link where I found this info: systemd.service(5) — systemd — Debian bullseye-backports — Debian Manpages

Summarizing this and the answer to your question is when you find a service on the system and maybe it is foreign to you or you don’t know why it’s there or maybe it shouldn’t even exist on the system you can quickly see when it activates and when it stops from that point you get a little more knowledge about the service, and can use that info to further examine the situation


Try to run the command on root first, if still doesn’t work, try what @marek33366 posted and then try
the command systemctl show syslog.service. you should get your answer.

Hope that helps :slight_smile:

1 Like

Just simply use:
systemctl show syslog.service

in result, it will list all properties associated with “syslog.service” . And in the list youcan find type property.

Moreover can use:
systemctl show syslog.service | grep Type

Note: T is capital in Type, don’t replace captal ‘T’ with small ‘t’.


System Logging Protocol facilitates the transfer of information from network devices to a central server, known as syslog server, in a particular message format.

1 Like

Why does this field not exist in my vm? Running parrotOS 5.2

systemctl show syslog.service | grep "Type"

If you tried the command I originally posted and it didn’t work, if syslog service is already installed on your system try reinstalling it. I am on my phone right now so I do not know will this work but try:
purge rsyslog
apt install rsyslog

No it definately works but… Works differently. There is no “Type=notify” field