VS2019 can't use .net 2.1

heyheyhey I got a biiig problem mates (and girls and whatever) I got my CommandoVM custom made goodness going but… VS2019 only let me select .net 4.x SDK - I installed all matching versions, 2.1 3.1 … FOR VS2019! I know there’s different versions but it’s not working

and when I edit a project file to use 2.1 or open one that’s .net 2.1 I get the “select version” dialog and if I select 2.1 it’s like “hey this version is not instlaled on your PC, wanna download” and I’m like “yeah hell I want to” but the link is dead and if I search myself there’s a MS download page but it doesn’t help I can only make 4.x version projects and that’s really really bad for hacking cause lots of tools are for 2.1

And I’m on Windows 10 64bit of course here’s the download page:

so you know I’m not an idiot I download FOR VS2019 but still no gold, no glory

Common what’s up why nobody gonna answer my topics? I could need some help for real…