Unified machine jdni payload not working

Hello,

I am currently trying to pwn the Unified machine from starting point tier 2. Unfortunately I can’t seem to get it right despite my best attempts. I cannot get a reverse shell on my netcat listener by using the jdni tomcat payload, despite jdni returning me the correct message upon sending the forget request to the unify server. It seems to me that the payload isn’t functionning properly, as it does not seem to prompt the server to connect back to the specified port on my machine (4444 in my case). Has anybody faced this kind of problem before?

3 Likes

Yes, exactly the same for me, nothing is piped to the netcat listener.

1 Like

yeah the same issue here…if you solved it please share the idea

have any idea …? or solved it yet…?

yeah same i was facing and i solved it there is little mistake while encrypting the payload to base64 …

Don’T Mind the Gap

xyzfymnkklnfhi |base64

1 Like

I actually didn’t use this method. When looking over the writeup afterword, I tried to follow along and had the same problem everyone else is reporting. There is another way to do it though.