Traverxec

Rooted! Once the port issues settled down it was a fun box! Thank you @jkr!

Tips:

Foothold: read other comments posted here, enumerate and you are in

User: Ditto, read the manual, understand how things works and are set up this will point you to where you need to go

Root: GTFO Bins and just seeing what is right there is all you need.

General advice: keep it simple, enumerate, read, google, take stock of what you have (often right in front of you).

Rooted :stuck_out_tongue:
For the user you should read a config file and the manual of the service, only the thing that matters.

For root, Swagshop’s root had almost the same approach as this one.

Great box, finally rooted. Learn to remember my ssh toolbox

I’ve found the creds and read the contents of n******* dir but can’t see anything to use. Is it the ht****** section or the ho****** section that I should be looking at? I noticed I can view a private space but no where to use creds.

any nudges from here?

EDIT: I’ve manged to find another interesting dir, the hunt continues :slight_smile:

got user, but needed some help to clear my mind!

Root is troll…but I love it.

Rooted,

Feel free to PM if you need nudges

Rooted.

Fun box, straight forward.

Rooted, many thanks to terrats for the last root hint.
Didn’t know pipes could do that :slight_smile:

My feedback for Traverxec:
The box is almost straightforward the annoying thing is that web server keeps dying not sure if that is because people are dossing or some kind of weird unstable machine.
anyway here is how I see the steps to root.

initial: recent CVE after light enumeration gives you quick win

User: enumeration of of the door that let you in gives you a bit of usefull info… for me this is sligtly CTF-y and requires a bit of guessing but once found gives you the user with a bit of extracting/cracking

Root*: quick enumeration would lead you to something… if you are not familiar google it, try it locally and go back and root the box :slight_smile:

  • Make sure you do not maximize your terminal screen a lot … sometimes LESS maximizing is better :slight_smile:

PM if you are stuck

Any assistance with root? I know about GBs, the dir to place the file in and that p** has something to do with it but unsure from here

haha. first the box is down for pretty much most of first day. Now I know exactly how to get root… and it doesnt work. I know it is the way but it doesnt work… so annoying.

To echo a previous comment, you need to try a different terminal if you are stuck at trying to get root and aren’t making headway. Things will function/display differently.

No idea why this is the case, but it cost me well over an hour of time.

Type your comment> @ALK said:

For people struggling with root. remember its not always a good idea to maximize ur screen :wink:

this unblocks me for root flag, thanks br0

Im kinda lost, got d**** credentials, but no idea where to go next

Just rooted !

Thanks for the machine @jkr ! I wonder where did you get the inspiration for the root flag, it reminds me one of the levels of bandit, the one that i struggled with the most !

I say something strange when i got in the user, hints from the guys on this thread helped me a lot ! i think they provide enough info already ! I would chat with someone who got root too ! the usual thing that i do didn’t worked, but i just tried something that seemed weird on my enum and it worked, coupled with the hints on the forum and got it !

Would love to hear from you @jkr, Thanks again !

I have tried and tried and that port is always “closed”

Struggling to crack creds. The usual tools finish almost instantly with a false alarm.

Anyone with a PM to help with syntax? Feel like I’m doing something silly.

Struggling with what to do with credentials of d****. I have RTFM multiple times and have the credentials cracked, just not quite getting what I have the ability to do under the unprivileged user…

Any nudges appreciated, PMs as well.

I got in and found the an interesting, plain view treat but cracking is taking forever? Weird