Safe

shellshock in high port ?

Type your comment> @b4nna said:

shellshock in high port ?

trying the same…not working though

i’ve tried knocking too but no one is answering

You don’t get an echo after a certain number of characters. Does that help?

@thegingerninja

delete this post pls

@edit
bad hint, i was totally wrong

echo back…i have no idea what to do with that…

Type your comment> @mario713 said:

I managed to force that high port to cooperate. There was one machine on htb where you had the script with ping command and you had to escape it(to get root if i remember correctly), this is something similiar except you need a little bit more than that.

If this hint is too much then let me know and ill edit my post, im noob so I have problems with giving good hints.

Hey Luke,

what is people have not done that box?

Any good articles for decompiling an ELF?

I understood (I hope) what should I do on the high port but it doesn’t execute… how do I make it work? I mean how can I escape the protection…

Any hints on root ?

if we need to do what i think we need to do with the tottaly dope port, thats soooo cool :slight_smile: im loving this

Yeah i think i was wrong. Overexcited :slight_smile: well pushing on

Guys, ignore my previous comments, im noob and I got trolled(by myself), these command execution worked locally :neutral:

Whoever uninstalled python and python3 is a sadist…

How even this box got approved. wasted my precious time today on this. Its simply copy of previous ones…

@D4nch3n Why not add your SSH key to authorized_keys if you have RCE?

Type your comment> @snowscan said:

Why not add your SSH key to authorized_keys if you have RCE?

Whoooooops I forgot you can do that…

Thanks haha

deleted

deleted

i have binary local exploitation in my machine, but doesnt work remote…