Pathfinder [Starting Point]

[TLDR] BloodHound not working like in the photos, Impacket script not working at all

Has anyone else had any issues at all with this machine? I’m running kali 2020.1b in VMware Fusion 11.5. Not like that should matter but w/e

I had bit of trouble just getting neo4j and bloodhound working, which, all I finally had to do was create a couple of folders for neo4j to work, and then load the initial interface @ localhost:7474 to set a password (because neo4j/neo4j was not working). After doing all that, BloodHound opened flawlessly, got logged in, and I was able to drag/drop the json files. Got the queries figured out.

However, attempting to use ./GetNPUsers.py (even as sudo) yields a traceback error about a module not loading:

ImportError: No module named pyasn1.codec.der

yet trying to install that module with pip yields:

Requirement already satisfied: pyasn1 in /usr/lib/python3/dist-packages (0.4.2)

Anyone else experiencing this?

Edit: Got BloodHound working correctly, use the built-in queries

Edit: Got the GetNPUsers script working. Needs to be run with python3

Cheers guys, this thread can be closed

i think u dint install impacket, also u cant pip impacket files, start by install impacket files first, jzt after git cloning impacket tool, cd to impacket folder and type “python3 setup.py install”, to install all the impacket files, i think not installing impacket may cause a prblm in running neo4j

Type your comment> @Ja4V8s28Ck said:

i think u dint install impacket, also u cant pip impacket files, start by install impacket files first, jzt after git cloning impacket tool, cd to impacket folder and type “python3 setup.py install”, to install all the impacket files, i think not installing impacket may cause a prblm in running neo4j

Installed /usr/local/lib/python3.7/site-packages/impacket-0.9.22.dev1+20200327.103853.7e505892-py3.7.egg
Processing dependencies for impacket==0.9.22.dev1+20200327.103853.7e505892
Searching for flask>=1.0
Reading Links for Flask
Download error on https://pypi.org/simple/flask/: unknown url type: https – Some packages may not be found!
Couldn’t find index page for ‘flask’ (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading Simple index
Download error on https://pypi.org/simple/: unknown url type: https – Some packages may not be found!
No local packages or working download links found for flask>=1.0
error: Could not find suitable distribution for Requirement.parse(‘flask>=1.0’)

no install/ help

guys, I’m trying to use secretsdump.py but it throws me two errors. it looks like this:

root@kali:~# secretsdump.py -dc-ip 10.10.10.30 MEGACORP.LOCAL/svc_bes:Sheffield19@10.10.10.30
Impacket v0.9.21 - Copyright 2020 SecureAuth Corporation

[-] RemoteOperations failed: ‘ConnectionResetError’ object is not subscriptable
[* ] Cleaning up…
[-] SMB SessionError: STATUS_INVALID_PARAMETER(An invalid parameter was passed to a service or function.)
[* ] Cleaning up…

what am I doing wrong???

@sincera Apologies for potential offtopic, just wanted to say thank you for posting how you got neo4j/bloodhound working, it has definitely saved me a headache when doing this box!

At the line “neo4j start console” it says “unknown argument console”. It seems like only one argument is need. I tried just start and console and it’s running but I’m not prompted to input password so I can’t log in… I don’t know what to do with it… (upd: skipped this step)