Official Surveillance Discussion

This box has lots of uno reverse action. Also reminded me a popular computer war game i have been playing about 20 years ago. Happy hacking everyone.

Im really confused in how to get the root … ! any hints please
i tried a lot of POC’s … nothing worked

do i need to do port forwarding for root ???

need help for root…

Ok, I’ve a foothold but I’m stuck at getting user. Enumerated the soul out of me but no clue yet.

Can someone give me a little hint?

##Edit:
I’m sure, it’s something absolutely simple I just don’t consider.

I’m having problems with root. I’ve checked a lot of things and forwarded ports over SSH, but none of them are responding… I don’t know exactly what to do now. Any little help would be appreciated.

Edit: Never mind, i got it

Thank you all.

Rooted, interesting box, needed a lot of searching.

Main issues:
Needed to fix PoC in one case and in the second i needed to create PoC after not finding any on the web after searching for 30 minutes.

(If you need some help with PoC’s or some hints then send me a private meesage)

Foothold: just a quick google.
User: look more on the file system, running services and ports.
Root: simple stuff, but, needed to search a lot of scripts.

1 Like

yeah for getting another user

Got 2 bcrypt hashes but no luck in cracking em. Been trying all kinda wordlists for well over a day. Anyone who cracked them hashes drop a hint on the wordlist please?

I use the poc with open burpsuite (i forward the requests made by the script) but yet “shell” that spawns is not functioning (I use id and other comments with no response). Any help would be appreciated.

I had trouble with the forked poc but the original was working otherwise check in the poc the url of the shell if it is on the server you should interact with it via url.

bro, can u help me with the root flag? im stuck on the root privesc, the password i got from the linpeas script isnt the correct one

Do we have to login into the

no , but there is an other poc for it

1 Like

Any one could give me a nudge on the last step to root? I’m super close but stuck

1 Like

I have saved first hash as laptop_heater :face_with_hand_over_mouth:

1 Like


Gettting this error. Any hints??

same issue. did you solved it?

Hello everyone.
I’m trying to gain root access. I’ve already established a reverse connection on ZoneMinder, but I’m unsure if it’s necessary for anything. I’m aware that a root process is updating two log files every 5 seconds. Someone mentioned in this discussion that to obtain root access, one should investigate numerous scripts (or something similar). I’m attempting to identify the program/process/script responsible for writing to the log files, but I haven’t found any leads. Could anyone provide some hints? I’m currently stuck at this stage.
Thanks in advance.

I do not understand why the POC in the foothold isn’t working. I read some writeups that you need to edit the place where you see the proxy… localhost:8080 or 127.0.0.1:8080. But I dont know with what information I have to edit it. I really dont understand. If someone can explain me or give more info I will appreciate it, I want to understand what is going on. The PoC without that modification do not work.

1 Like