Official RedPanda Discussion

Stuck at reverse shell for days can someone gimme a nudge.

This tool will help you
It’s also important to know that sometimes stars are more useful than dollars ($).

This guy’s post on Official RedPanda Discussion - #34 by JacobE should help you.

anyone know how to get the revshell? i try many payload but keep failed

Finally pwned.

The xxe was not easy to understand at first glance.

Thanks all for the tips that can be found in this thread!

1 Like

Do you mind if I DM you? I’m stuck and honestly don’t know what to do anymore

No problem mate!


Wow…When you get the user flag and you’re like…“easy” and then the root flag…Difficulty is not comparable :dizzy_face:, but in the end, a great and fun machine, learned a lot of new things!

If anyone needs help, just DM. I won’t give you any answers…but tips :).

One tip…try it out on your local machine first…

And also if anyone wants to talk about there solution over discord, would love to, I wonder if the way I got it was way over thought… :rofl: :rofl: :sweat_smile:


Nice machine, easy foothold/user, medium root - all the nudges here in the topic already, it still needs some trial and error until you can pull off the root
“fake it till you make it” but fake it right :smiley:

although it is not the intended way but anyone tried this?

Can someone help me with getting a reverse shell?

I had an interesting scenario with this where /stats never updated. No matter what I did. Don’t know why that is, and it did make things a little harder to figure out. In the also process of priv esc I think I also figured out why this feature wasn’t working.

As others have said, difference in difficulty between user and root is a lot. So don’t feel bad if you get stuck on root. Definitely not an Easy box when it comes to priv esc. Getting root took me a few days and was not easy. But I learned a lot and found some new useful tools. Thanks to @ZuZu for the help :smile: All the hints you should need are already in this thread, and if you’re still stumped just DM someone.

Just go user flag.
I think the vulnerability wasn’t that hard to figure out if you follow some basic fuzzing guidelines.

I got code execution with response on the site but didn’t succeed in getting a shell just yet.

Currently reading trough the docs of the github repo posted here.

Happy hacking my friends :heart_eyes:

Maybe this thread is holding too much spoilers imo :see_no_evil:

Rooted! Pulled out some hair while getting reverse shell, but it was worth it… very interesting privesc!!! PM me if you need a help :wink:

Has anyone had issues with get a reverse shell to connect to the listener?

I have the reverse shell loaded succefully and can see it actually loaded. however when i run it nothing happens. ive tryed python, bash, and .elf. nothing works…

Ive also looked for any human errors or wrong ips and ports but all looks good.

I got a shell yesterday after some trial and error. Im far from an expert in the field of this type of exploitation but i would be glad to try and help you out. Dm me and show me what you tried :innocent:

Absolutely lost on the privesc. From looking at the thread I’m seeing things about XXE, but I’m completely lost as to where you would do that, and why would that be a solution. I’d like to PM someone if I can.