Official Omni Discussion

Nice Box, after spend time to understand the environment it is quite simple, but not too much, some interesting things i learned. thanks to @egre55

Rooted! That was a fun box and I learned a lot doing it. It was interesting being that root was the exact same as user. If you get one, you have the other too.
The hardest part was the ‘hashes’. If you’re struggling with that, read the file more and read up on the class you see.

Took some time off this box after getting stuck on a reverse shell part. Found my reverse shell issue was just an issue involving slashes (so mad I had the right way about it but just making a stupid mistake wasted hours and caused me to try alternate routes). After that it is pretty simple.

Running the script, I’m able to view the host file, run basic commands, ping myself, download files from my hosted web server, but not able to write to a file or execute scripts directly from memory. I’m using PS for commands on the box, as CMD output was unreliable. I’m searching for a writable directory to save my shell binary but am not finding anything. I’ve tried diff variations of temp directories, but not seeing any indications from script output that files are saving. Any nudges on writable directories or course correction to gain initial shell?

Totally lost after getting initial shell, can’t find this file I’m supposed to, anyone able to provide a hint via DM?

@beauchompers said:

Totally lost after getting initial shell, can’t find this file I’m supposed to, anyone able to provide a hint via DM?

Powershell has useful ways to search for things. Often using that can help.

Rooted!!!
ping me for any hints and tips

I understand I am a little out of practice, but what I’m missing in here is beyond the rustiness I could have. Could someone ping me and assist with nudges? I have a remote shell and certain files. I can’t import certain xml file to then try and retrieve the creds as it errors out.

@grav3m1ndbyte said:

I understand I am a little out of practice, but what I’m missing in here is beyond the rustiness I could have. Could someone ping me and assist with nudges? I have a remote shell and certain files. I can’t import certain xml file to then try and retrieve the creds as it errors out.

Happy to help if I can but I dont know what XML file you are trying to import.

Thank you @TazWake

I’ll DM you shortly and explain where I’m at. I’m probably more frustrated than what I should.

I am having troubles with the last part too, I got into the machine, and I am having troubles to find the right file or maybe I have seen it but I dunno how to use it :dizzy:

ROOTED!! Wow, that was definitively a nice ride and a different kind of machine. Thanks to @TazWake for the nudge and congrats to @egre55 for another great box!

Some help over here !! … this OS is very peculiar I have the shell but I´m not be able to see any User on Users folder also y tried something like SystemInfo with my terminal and it does not exist. I tried in the userprofile folder and it doesn´t have anything !!! currently I have the shell but without any User :S …

currently I have access to both user moving to other part of the disk !! the last part comes with Cryto… right ?

@H4FN said:

currently I have access to both user moving to other part of the disk !! the last part comes with Cryto… right ?

Not really. But the content you thought as Crypto has a hint for what algorithm is used behind to encrypt.

Type your comment> @gunroot said:

@H4FN said:

currently I have access to both user moving to other part of the disk !! the last part comes with Cryto… right ?

Not really. But the content you thought as Crypto has a hint for what algorithm is used behind to encrypt.

I´m woking on it ! but it looks that I have an error importing it.

I´m stuck even after login with user and password when I try to import the flags I have this error Error occurred during a cryptographic operation. and before I had this message Access to the path ‘***********’ is denied.
I did all my research and look that I must import but I have those errors :frowning:

am I missing something else or cryptographic operation is not working properly ?

@H4FN said:

am I missing something else or cryptographic operation is not working properly ?

The account matters.

I am able to write Powershell files, execute the Powershell scripts written, but I am failing to execute any of the usual PS reverse shells I’ve used in the past. Could someone PM me with some help. Thanks.

Type your comment> @thegingerninja said:

I am able to write Powershell files, execute the Powershell scripts written, but I am failing to execute any of the usual PS reverse shells I’ve used in the past. Could someone PM me with some help. Thanks.

Stuck at the same spot. Please let me know what you hear.

Type your comment> @H4FN said:

I´m stuck even after login with user and password when I try to import the flags I have this error Error occurred during a cryptographic operation. and before I had this message Access to the path ‘***********’ is denied.
I did all my research and look that I must import but I have those errors :frowning:

am I missing something else or cryptographic operation is not working properly ?

If you store your password encrypted in a file, would you let anyone to decrypt it? ?