Official Authority Discussion

Anyone needing a nudge, feel free to DM. Just let me know where you’re at and what you’ve done.

Hello, I meet this error, do you can help me please : -] Got error: Unknown DCE RPC fault status code: 00000721
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/certipy/”, line 60, in main
File “/usr/lib/python3/dist-packages/certipy/commands/parsers/”, line 12, in entry
File “/usr/lib/python3/dist-packages/certipy/commands/”, line 767, in entry
File “/usr/lib/python3/dist-packages/certipy/commands/”, line 718, in request
cert = self.interface.request(csr, attributes)
File “/usr/lib/python3/dist-packages/certipy/commands/”, line 208, in request
response = self.dce.request(request)
File “/usr/lib/python3/dist-packages/impacket/dcerpc/v5/”, line 859, in request
answer = self.recv()
File “/usr/lib/python3/dist-packages/impacket/dcerpc/v5/”, line 1332, in recv
raise DCERPCException(‘Unknown DCE RPC fault status code: %.8x’ % status_code)
impacket.dcerpc.v5.rpcrt.DCERPCException: Unknown DCE RPC fault status code: 00000721

i have a same problem

Hey, if you got the same DCE RPC 0000721 error as me, here is how I managed to fix it in Kali specifically.

  • Use network manager rather than directly editing resolv.conf.
  • Add the authority IP to your DNS servers, and authority.htb to the search domains.
  • Restart network manager sudo systemctl restart NetworkManager
  • Cat your resolv.conf and ensure the entries are there now.
  • Use the tool. Give it a couple tries, it worked for me the second time around.

Really liked this machine, but the unreliability of the tools on the privesc part kinda ruined it for me, and obviously bumps the overall difficulty. If your tools keep failing just because, and you’re not familliar with the vuln at hand, it makes it hard to distinguish between whats intended difficulty and whats just technical difficulties.

DM if you need a nudge in the right way.

Really enjoyed the priv esc on this box as it takes a super common and easily exploited vulnerability in the real world and teaches you how to resolve a common error that you can run into. I’ve seen the same error on live pen tests and already knew two alternative methods that did not work on this box.