.htb domains redirected to search results fix

Hi, I would like to know your opinions. After several months of struggling with hitting the search results while trying to access the htb machines after adding them at /etc/hosts I found that adding “browser.fixup.domainsuffixwhitelist.htb” into the firefox config at “about:config” solved this for me at every htb domain. Are there another or better fix-ups for this?

I just add the http:// prefix before going to the domains, much easier than messing around with settings. No need to overcomplicate it.

I used to do that for almost a year, and I know it’s much easier, but sometimes when playing with the URL the browser pushed me again to the search results and it was like “Agh, not again…”, or when just typing the domain without remembering it’s a htb machine.
Even in one ippsec video (I don’t remember which one) he also got frustrated and disabled the auto search option of the browser XD
Now i’ve been using this configuration for almost a month and I am so much more comfortable.