Chatterbox

DEFINITELY DEFINITELY DEFINITELY recommend installing a local copy of whatever you find and testing your own payloads on it. (as some others have mentioned)

Also helps to read what the bad characters are (I think I wasted an hour or two wondering why nothing was working…). I used the python script.

My first attempt doing it on the box ( after figuring stuff out locally) went off flawlessly.

Totally agree. Install a local copy of vulnerability service and try on a local vm. Once you find the correct exploit, it really is a simple machine. I 100% recommend a reset before launching it on the lab, because it only works once.

you can use sparta for recon and enumeration, it’s amazing toolkit.
full port scan will reveal sufficient info for you to go ahead with.
I am stuck with the exploit right now, wasted 2 days to figure out what is missing.

ok so I got root.txt without actually spawning an Administrative shell. I’d like to understand how to go about using the privileges I have to get an interactive shell as Admin. Anybody willing to PM me a hint to point me in the right direction?

@peek said:
try allports

Great advice if you could even scan the thing without being fucked over by reset. Sorry for the language but I’ve spent weeks on this piece of crap, even wrote scripts to automatically scan small blocks of ports spanning the entire range just to find a single open port. Only to find zero in the morning.

For all of those complaining about the slow port scanning, I’d recommend reading up on some nmap flags/options to help get around what’s causing the slow down. With the proper flags, you should be able to port scan the entire box fairly quickly.

Finally.
---->{P00F}!
For real.

Tried nmap and masscan, several times, all ports, fast, and twice found one port, but not the same port, and all the other times just found nothing :confused: even after reseting the box

This box is driving me nuts

Nvm, F#ck this box.

Can I DM someone to help with payloads?

it would be lovely because chatterbox is requested to reset so much.

@puerkito66 said:
Nvm, F#ck this box.

My thoughts exactly. It took me days to find the port, and now days on days to figure out the payload and I’m still not there.

masscan shows me no port is opening, no matter my option (stealth scan, udp scan - for sure). is masscan that bad?

@dmknght said:
masscan shows me no port is opening, no matter my option (stealth scan, udp scan - for sure). is masscan that bad?
The problem with this box is that it can be exploited once at the time, the moment it’s being exploited, the useful port become “invisible”, it’s better with a fresh reset :confused:

SPOILER: uncommon port, DON’T SPAM reset request.
If your nmap is so slow, use this option --min-rate

Jeez, finally got a working shell that lasted longer than 20 seconds and rooted, glad to be over this one, the inconsistent shell was driving me mad

So when creating the payload, I’ve managed to get one to encode but the size is no where near 512.

Tried a few different payloads as well as changing some of the buffer length.

Sort of on the right track for a working buff ?

@IVWKCSEC said:
So when creating the payload, I’ve managed to get one to encode but the size is no where near 512.

Tried a few different payloads as well as changing some of the buffer length.

Sort of on the right track for a working buff ?

Does size really matter, at least in this case :slight_smile: ?

@PencilTester said:
Finally.
---->{P00F}!
For real.

I’m guessing you’re talking about the python exploit.
What does it do? I can’t figure it out reading the source.

@junior said:

@IVWKCSEC said:
So when creating the payload, I’ve managed to get one to encode but the size is no where near 512.

Tried a few different payloads as well as changing some of the buffer length.

Sort of on the right track for a working buff ?

Does size really matter, at least in this case :slight_smile: ?

Haha thats what they all say !

I’ve tried with a custom payload … basic one of a shell_tcp but it never connects back.

I’ll have to keep trying /setup it in a local lab to get it working.