Bloodhound on Parrot Box broken

Bloodhound does not work Parrot. The neo4j version is too low and when you try to connect bloodhound to it it gives you an error. For some reason when you try to follow the install instructions for neo4j on the bloodhound website

wget -O - https://debian.neo4j.com/neotechnology.gpg.key | sudo apt-key add -
echo ‘deb https://debian.neo4j.com stable latest’ > /etc/apt/sources.list.d/neo4j.list
sudo apt-get update

the Parrot OS still won’t install a newer version than 2.1 and when you try to force it by putting =4.4.13 after neo4j apt insists that the version doesn’t exist. This is a big problem. Some of the boxes like Forrest can not be solved without bloodhound. I like Parrot, but hate the fact that some of the tools are broken by default. There’s nothing more I hate than getting half way through a box and then having to switch over to my Kali machine because a tool is broken in Parrot and I can’t fix it (unless someone can give me advice on how). When will this get fixed?

1 Like

I agree that this is a problem. I was lucky enough to resolve the issue while hacking Forest by downloading Bloodhound v3.0.5 which is compatible with the neo4j version installed on ParrotOS.

One recommendation I have (if you can do it) is to spin up your own VM and work on installing a toolkit with more recent versions. But if you are limited to only using the cloud VMs provided by HTB then I hope someone from HTB can put in a request to upgrade the ParrotOS repos.

Good luck!

Hey @Apache30, I’ve been battling the same issue for the longest time and stumbled across this article by @aut0exec this evening and I’ve managed to get bloodhound up and running perfectly on a fresh Parrot OS install

Hopefully this helps others in the community too!

1 Like

I resolved errors and somehow ran it. After, I found out that the newest version at this time for parrot linux 4.0.3 has a bug. So I have everything necessary but I am unable to load files into bloodhound and have to change systems to be able to use bloodhound.

Hey @Kuro,
I have the same issue and the same BloodHound Version:

└──╼ $dpkg -l | grep bloodhound
ii  bloodhound                            4.0.3-0parrot1 

Kali Linux worked without issues
I also tried what suggested from @breacher but no luck.
My Parrot is:

└──╼ $uname -a
Linux parrot 6.1.0-1parrot1-amd64 #1 SMP PREEMPT_DYNAMIC Parrot 6.1.15-1parrot1 (2023-04-25) x86_64 GNU/Linux

Any other suggestion?
Thanks

U can probably try to install newest version of bloodhound directly from github. When I tried I kinda gave up because it meant, that I would also have to install a bunch of other packages directly from github. I just found the change of systems to be the fastest option.

Hi Kuro,
Thanks for the response.
I tried the same installation in Kali linux and the same file was able to be fully uploaded.
I managed to install BloodHound in Parrots Os using:

sudo apt install bloodhound -y

And downgrade Java

sudo update-alternatives --config java
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                         Priority   Status
------------------------------------------------------------
* 0            /usr/lib/jvm/java-17-openjdk-amd64/bin/java   1711      auto mode
  1            /usr/lib/jvm/java-11-openjdk-amd64/bin/java   1111      manual mode
  2            /usr/lib/jvm/java-17-openjdk-amd64/bin/java   1711      manual mode

Press <enter> to keep the current choice[*], or type selection number:1

But the problem is that when importing a zip or json it gives me 100% uploaded but no data is provided.
Using the same files in Kali Linux it worked just fine.

I found, this issue BloodHound 4.0.3 Release - Skips the computers.json file when importing from zip file. · Issue #487 · BloodHoundAD/BloodHound · GitHub (I think ) it corresponds to your problem. You can try to look up the problem further, but I fell like the most reasonable thing to do is just to wait for the updates from parrot or hackthebox to fix pwnbox in this matter.

I think I found the issue.
I tried to connect to a PWNDBOX and check what BloodHound version is running and instied of the 4.0.3 they have 4.2.0, then I upload the file and everthing worked in their pwnd box.
What I am not able to do it to install that version to my Parrots Security VM. I found the version here Releases · BloodHoundAD/BloodHound · GitHub